Exporting Report Results

Exporting Report Results

This article is about exporting report results - saving report data in another format (Excel, PDF, etc).

Mercury also offers another type of export - exporting the report definition.  You might wish to do this for backup purposes or for subsequently importing into a different installation of Mercury. This type of export is done via Tools > Admin Tools > Reports.

This article describes the standard method for exporting report results, which uses the ribbon controls. There is also an export available via the "Print Preview" window.

The print-preview export operates slightly differently than the method described here and in some cases may offer a different set of export options.

If you want to export via Print Preview, click
 here.

Use the "Export" button in the ribbon to export your report results.  You’ll find the export button in two places:
  • the Home tab of the main window.  
  • the report’s own ribbon tab (the Pivot Report or Table Report tab, as the case may be).

The Home ribbon tab


The Pivot Report ribbon tab  (Table Report tab not shown)


There are several export types available.  

  
When you choose an export type, you’ll see a window similar to the one above. You specify the name of the output file (or browse to select it) and whether you want the file to be automatically opened after it’s created.

You can expand More Options for additional control over the export (click on the triangle to expand/collapse).

The specific options available depend on the export format. 

You may be offered options for controlling the export layout (e.g. if Excel, do you want explicit gridlines?) and possibly a set of options for specifying header/footer content.

Excel "More Options" - Export Options tab


Excel "More Options" - Header & Footer tab



    • Related Articles

    • Exporting Report Results

      This article is about exporting report results - saving report data in another format (Excel, PDF, etc). Mercury also offers another type of export - exporting the report definition. You might wish to do this for backup purposes or for subsequently ...
    • The Pivot Report Ribbon

      General Run - Run the selected report (values for all parameters must be supplied for this to be enabled). See Running Pivot Reports for more information. Print and Quick Print - See Printing Reports. Export - See Exporting Report Results for more ...
    • The Table Report Ribbon

      General Run - Run the selected report (values for all parameters must be supplied for this to be enabled). See Running Table Reports for more information. Print - Print the current report. See Printing Reports for more information. Export - Exports ...
    • Report List

      The Report List contains all the reports available to you. You can change its appearance in several ways. You can change how the list is presented To change the list appearance, use the small icons above the search box. Icon Description The pin ...
    • Report Canvas

      Report results appear in the main window to the right of the report-list. This region is called the "report canvas" or the "results area". You can open (i.e. run) as many reports as you like, including multiple runs of the same report with different ...