After logging in all menu options are disabled

After logging in all menu options are disabled

Symptoms

After logging into the Solatech Window Covering Software all the menu options under Edit, View,Reports, Products, etc. are disabled.

Cause

This can happen if the database is in single-user mode.

Resolution

The database needs to be switched to multi-user mode. To do this you need to run Microsoft SQL Server Management Studio Express.

  1. If running, close SWCS on all computers, even the server.
  2. Click Start, Programs, Microsoft SQL Server 2005, SQL Server Management Studio Express.
  3. Log in to the server that stores the SWCS data. If you don't know what server to use see the section Finding the Server.
  4. Expand the list of database from the Object Explorer list on the left.
  5. Locate the database that SWCS is using. If you don't know what database to use, see the section Finding the Database.
  6. To the right of the database name should be the word (Single User). If you don't see this then do not proceed as the problem is something other than single-user mode.
  7. Right-click on the database and select Properties.
  8. From the list of pages on the left, click Options.
  9. From the list of properties on the right, scroll to the bottom and locate the property called Restrict Access.
  10. Change it's value from SINGLE_USER to MULTI_USER.
  11. Click OK.
  12. Close SQL Server Management Studio Express.
  13. Run SWCS normally.

Finding the Server

  1. Run the Solatech Window Covering Software.
  2. If the software attempts to open the company automatically, wait until you get a login screen, then click Cancel.
  3. Close all dialogs until you get to the main menu.
  4. From the File menu click File Manager.
  5. Select the file type Companies.
  6. On the toolbar click Open.
  7. From the View menu select Details.
  8. Click the Name column header to sort the files by name.
  9. Locate the name of the company you were trying to open. There should be three files with the same name.
  10. Of the three files, locate the one with the File Type of 'PSD File'.
  11. Holding the Shift key down, right-click on that file name.
  12. From the menu click Open With...
  13. Open the file with the program 'Notepad'.
  14. In notepad, look for the word '<Host>'. To the right of this word, between <Host> and </Host> is the server name. Write this name down.
  15. Close Notepad.

Finding the Database

  1. Run the Solatech Window Covering Software.
  2. If the software attempts to open the company automatically, wait until you get a login screen, then click Cancel.
  3. Close all dialogs until you get to the main menu.
  4. From the File menu click File Manager.
  5. Select the file type Companies.
  6. On the toolbar click Open.
  7. From the View menu select Details.
  8. Click the Name column header to sort the files by name.
  9. Locate the name of the company you were trying to open. There should be three files with the same name.
  10. Of the three files, locate the one with the File Type of 'PSD File'.
  11. Holding the Shift key down, right-click on that file name.
  12. From the menu click Open With...
  13. Open the file with the program 'Notepad'.
  14. In notepad, look for the word '<CompanyDatabase>'. To the right of this word, between <CompanyDatabase> and </CompanyDatabase> is the database name. Write this name down.
  15. Close Notepad.

Applies To:

  • Solatech Window Covering Software 4.2

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